#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)describe\('[^']*', function \(\) {.*?it\('([^']*)-Expected result-([^']*)',"
Local $sString = "describe('Criteria and Adjustment Section', function () {" & @CRLF & _
" it('the labels should have correct spellings -Expected result- the labels have correct spellings', function () {" & @CRLF & _
" //some logic" & @CRLF & _
"});" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"describe('Test 1', function () {" & @CRLF & _
" it('Click on the company dropdown -Expected result- Four options will be shown', function () {" & @CRLF & _
" //some logic " & @CRLF & _
"});"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")