$re = '/describe\(\'[^\']*\', function \(\) {.*?it\(\'([^\']*)-Expected result-([^\']*)\',/ms';
$str = 'describe(\'Criteria and Adjustment Section\', function () {
it(\'the labels should have correct spellings -Expected result- the labels have correct spellings\', function () {
//some logic
});
describe(\'Test 1\', function () {
it(\'Click on the company dropdown -Expected result- Four options will be shown\', function () {
//some logic
});';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);