// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ms)describe\('[^']*', function \(\) {.*?it\('([^']*)-Expected result-([^']*)',").unwrap();
let string = "describe('Criteria and Adjustment Section', function () {
it('the labels should have correct spellings -Expected result- the labels have correct spellings', function () {
//some logic
});
describe('Test 1', function () {
it('Click on the company dropdown -Expected result- Four options will be shown', function () {
//some logic
});";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}