re = /describe\('[^']*', function \(\) {.*?it\('([^']*)-Expected result-([^']*)',/m
str = 'describe(\'Criteria and Adjustment Section\', function () {
it(\'the labels should have correct spellings -Expected result- the labels have correct spellings\', function () {
//some logic
});
describe(\'Test 1\', function () {
it(\'Click on the company dropdown -Expected result- Four options will be shown\', function () {
//some logic
});'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end