#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "FIRST[\s\S]+SECOND\|B"
Local $sString = "FIRST|[some text here]" & @CRLF & _
"[insert text here]" & @CRLF & _
"SECOND|A" & @CRLF & _
"" & @CRLF & _
"FIRST|[some text here]" & @CRLF & _
"[insert text here]" & @CRLF & _
"SECOND|B" & @CRLF & _
"" & @CRLF & _
"FIRST|[some text here]" & @CRLF & _
"[insert text here]" & @CRLF & _
"SECOND|A" & @CRLF & _
"" & @CRLF & _
"FIRST|[some text here]" & @CRLF & _
"[insert text here]" & @CRLF & _
"SECOND|B" & @CRLF & _
"" & @CRLF & _
"FIRST|[some text here]" & @CRLF & _
"[insert text here]" & @CRLF & _
"SECOND|A"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")