re = /FIRST[\s\S]+SECOND\|B/
str = 'FIRST|[some text here]
[insert text here]
SECOND|A
FIRST|[some text here]
[insert text here]
SECOND|B
FIRST|[some text here]
[insert text here]
SECOND|A
FIRST|[some text here]
[insert text here]
SECOND|B
FIRST|[some text here]
[insert text here]
SECOND|A'
# Print the match result
str.match(re) do |match|
puts match.to_s
end