using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"FIRST[\s\S]+SECOND\|B";
string input = @"FIRST|[some text here]
[insert text here]
SECOND|A
FIRST|[some text here]
[insert text here]
SECOND|B
FIRST|[some text here]
[insert text here]
SECOND|A
FIRST|[some text here]
[insert text here]
SECOND|B
FIRST|[some text here]
[insert text here]
SECOND|A";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}