const regex = /FIRST[\s\S]+SECOND\|B/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('FIRST[\\s\\S]+SECOND\\|B', '')
const str = `FIRST|[some text here]
[insert text here]
SECOND|A
FIRST|[some text here]
[insert text here]
SECOND|B
FIRST|[some text here]
[insert text here]
SECOND|A
FIRST|[some text here]
[insert text here]
SECOND|B
FIRST|[some text here]
[insert text here]
SECOND|A`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}