using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([äöüÄÖÜßa-zA-Z\-\. ]+)\s*(\d+.*)";
string input = @"Eichetstrasse 21
Meiereistr.28
Dominikus-Schneider-Str. 9
Lindacher-Str.48 d
Langeßallee27
Neuer Weg 68 B
Beuthener Str.9-15";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}