import re
regex = re.compile(r"([äöüÄÖÜßa-zA-Z\-\. ]+)\s*(\d+.*)", flags=re.MULTILINE)
test_str = ("Eichetstrasse 21\n"
"Meiereistr.28\n"
"Dominikus-Schneider-Str. 9\n"
"Lindacher-Str.48 d\n"
"Langeßallee27\n"
"Neuer Weg 68 B\n"
"Beuthener Str.9-15")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")