re = /([äöüÄÖÜßa-zA-Z\-\. ]+)\s*(\d+.*)/m
str = 'Eichetstrasse 21
Meiereistr.28
Dominikus-Schneider-Str. 9
Lindacher-Str.48 d
Langeßallee27
Neuer Weg 68 B
Beuthener Str.9-15'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end