$re = '/([äöüÄÖÜßa-zA-Z\-\. ]+)\s*(\d+.*)/m';
$str = 'Eichetstrasse 21
Meiereistr.28
Dominikus-Schneider-Str. 9
Lindacher-Str.48 d
Langeßallee27
Neuer Weg 68 B
Beuthener Str.9-15';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);