package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[[^]]+\]`)
var str = `This is [test] version`
var substitution = "1.0"
fmt.Println(re.ReplaceAllString(str, substitution))
}