import re
regex = re.compile(r"\[[^]]+\]", flags=re.MULTILINE)
test_str = "This is [test] version"
subst = "1.0"
result = regex.sub(subst, test_str)
if result:
print(result)