$re = '/\[[^]]+\]/m';
$str = 'This is [test] version';
$subst = "1.0";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;