package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^www\.example\.(?:com|co(?:\.(?:in|uk))?|net|us|me)(?:\/[^\n\/]+){2}$`)
var str = `www.example.com
www.example.com/
www.example.com/example1
www.example.net/example1/
www.example.co.uk/example1/something
www.example.co.in/example1/something/
www.example.com/example1/something/otherstuff`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}