re = /^www\.example\.(?:com|co(?:\.(?:in|uk))?|net|us|me)(?:\/[^\n\/]+){2}$/m
str = 'www.example.com
www.example.com/
www.example.com/example1
www.example.net/example1/
www.example.co.uk/example1/something
www.example.co.in/example1/something/
www.example.com/example1/something/otherstuff'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end