const regex = /^www\.example\.(?:com|co(?:\.(?:in|uk))?|net|us|me)(?:\/[^\n\/]+){2}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^www\\.example\\.(?:com|co(?:\\.(?:in|uk))?|net|us|me)(?:\\\/[^\\n\\\/]+){2}$', 'gm')
const str = `www.example.com
www.example.com/
www.example.com/example1
www.example.net/example1/
www.example.co.uk/example1/something
www.example.co.in/example1/something/
www.example.com/example1/something/otherstuff`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}