# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^www\.example\.(?:com|co(?:\.(?:in|uk))?|net|us|me)(?:\/[^\n\/]+){2}$"
test_str = ("www.example.com\n"
"www.example.com/\n"
"www.example.com/example1\n"
"www.example.net/example1/\n"
"www.example.co.uk/example1/something\n"
"www.example.co.in/example1/something/\n"
"www.example.com/example1/something/otherstuff")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.