#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)/(\d{2}-\d{2}-\d{4})\.csv$"
Local $sString = "csse_covid_19_data/csse_covid_19_daily_reports/02-01-2020.csv" & @CRLF & _
"csse_covid_19_data/csse_covid_19_daily_reports/01-31-2020.csv" & @CRLF & _
"csse_covid_19_data/csse_covid_19_daily_reports/02-02-2020.csv" & @CRLF & _
"csse_covid_19_data/csse_covid_19_daily_reports/01-24-2020.csv" & @CRLF & _
"csse_covid_19_data/csse_covid_19_daily_reports/01-29-2020.csv"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")