import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "/(\\d{2}-\\d{2}-\\d{4})\\.csv$";
final String string = "csse_covid_19_data/csse_covid_19_daily_reports/02-01-2020.csv\n"
+ "csse_covid_19_data/csse_covid_19_daily_reports/01-31-2020.csv\n"
+ "csse_covid_19_data/csse_covid_19_daily_reports/02-02-2020.csv\n"
+ "csse_covid_19_data/csse_covid_19_daily_reports/01-24-2020.csv\n"
+ "csse_covid_19_data/csse_covid_19_daily_reports/01-29-2020.csv";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}