package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)/(\d{2}-\d{2}-\d{4})\.csv$`)
var str = `csse_covid_19_data/csse_covid_19_daily_reports/02-01-2020.csv
csse_covid_19_data/csse_covid_19_daily_reports/01-31-2020.csv
csse_covid_19_data/csse_covid_19_daily_reports/02-02-2020.csv
csse_covid_19_data/csse_covid_19_daily_reports/01-24-2020.csv
csse_covid_19_data/csse_covid_19_daily_reports/01-29-2020.csv`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}