import re
regex = re.compile(r"/(\d{2}-\d{2}-\d{4})\.csv$", flags=re.MULTILINE)
test_str = ("csse_covid_19_data/csse_covid_19_daily_reports/02-01-2020.csv\n"
"csse_covid_19_data/csse_covid_19_daily_reports/01-31-2020.csv\n"
"csse_covid_19_data/csse_covid_19_daily_reports/02-02-2020.csv\n"
"csse_covid_19_data/csse_covid_19_daily_reports/01-24-2020.csv\n"
"csse_covid_19_data/csse_covid_19_daily_reports/01-29-2020.csv")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")