import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\[[\\d:]+\\s(WRN|INF|ERR)\\]";
final String string = "[12:00:49 INF] hello\n"
+ "[12:00:49 WRN] world\n"
+ "[12:00:49 ERR] 123\n"
+ "[12:00:49 INF] 123\n"
+ "[12:00:49 WRN] world\n"
+ "[12:00:49 ERR] hello";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}