import re
regex = re.compile(r"^\[[\d:]+\s(WRN|INF|ERR)\]", flags=re.MULTILINE)
test_str = ("[12:00:49 INF] hello\n"
"[12:00:49 WRN] world\n"
"[12:00:49 ERR] 123\n"
"[12:00:49 INF] 123\n"
"[12:00:49 WRN] world\n"
"[12:00:49 ERR] hello")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")