const regex = /"0+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"0+', 'gm')
const str = `original_ref_list = ["005a004",
"018b003",
"007a029",
"105a015"]`;
const subst = `"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);