import re
regex = re.compile(r"\"0+", flags=re.MULTILINE)
test_str = ("original_ref_list = [\"005a004\",\n"
" \"018b003\",\n"
" \"007a029\",\n"
" \"105a015\"]")
subst = "\""
result = regex.sub(subst, test_str)
if result:
print(result)