re = /"0+/m
str = 'original_ref_list = ["005a004",
"018b003",
"007a029",
"105a015",
"0000000",]'
subst = '"'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result