using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"color";
string input = @"If you write color multiple times in a text, the g flag will find all occurrences of the word color, instead of the first match only.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}