re = /color/
str = 'If you write color multiple times in a text, the g flag will find all occurrences of the word color, instead of the first match only.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end