package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`color`)
var str = `If you write color multiple times in a text, the g flag will find all occurrences of the word color, instead of the first match only.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}