import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "@sha256:.{64}$";
final String string = "redis@sha256:405b4b2fafecf50945309a7ac042ca4a29a624e97613026acff708c1d6af8232\n"
+ "redis:v1.2.3\n"
+ "redis:alpine@sha256:405b4b2fafecf50945309a7ac042ca4a29a624e97613026acff708c1d6af8232\n"
+ "service:version";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}