// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)@sha256:.{64}$").unwrap();
let string = "redis@sha256:405b4b2fafecf50945309a7ac042ca4a29a624e97613026acff708c1d6af8232
redis:v1.2.3
redis:alpine@sha256:405b4b2fafecf50945309a7ac042ca4a29a624e97613026acff708c1d6af8232
service:version";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}