re = /@sha256:.{64}$/m
str = 'redis@sha256:405b4b2fafecf50945309a7ac042ca4a29a624e97613026acff708c1d6af8232
redis:v1.2.3
redis:alpine@sha256:405b4b2fafecf50945309a7ac042ca4a29a624e97613026acff708c1d6af8232
service:version'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end