# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"@sha256:.{64}$"
test_str = ("redis@sha256:405b4b2fafecf50945309a7ac042ca4a29a624e97613026acff708c1d6af8232\n"
"redis:v1.2.3\n"
"redis:alpine@sha256:405b4b2fafecf50945309a7ac042ca4a29a624e97613026acff708c1d6af8232\n"
"service:version")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.