using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"logtype::[^ ]*\s+\w+id::IDB-28123.\w+\s\w+\s+username::\w+TEST";
string input = @" pppppppppppp logtype::ABC.123 pppppppid::IDB-28123.ppppp pppppppp username::ppppppp
pppppppppppp logtype::ABC.123 qqqqqid::IDB-28123.qqqq pppppppp username::qqq
pppppppppppp logtype::ABC.123 rrrrrrid::IDB-28123.rrr pppppppp username::rrTEST";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}