$re = '/logtype::[^ ]*\s+\w+id::IDB-28123.\w+\s\w+\s+username::\w+TEST/m';
$str = ' pppppppppppp logtype::ABC.123 pppppppid::IDB-28123.ppppp pppppppp username::ppppppp
pppppppppppp logtype::ABC.123 qqqqqid::IDB-28123.qqqq pppppppp username::qqq
pppppppppppp logtype::ABC.123 rrrrrrid::IDB-28123.rrr pppppppp username::rrTEST';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);