const regex = /logtype::[^ ]*\s+\w+id::IDB-28123.\w+\s\w+\s+username::\w+TEST/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('logtype::[^ ]*\\s+\\w+id::IDB-28123.\\w+\\s\\w+\\s+username::\\w+TEST', 'gm')
const str = ` pppppppppppp logtype::ABC.123 pppppppid::IDB-28123.ppppp pppppppp username::ppppppp
pppppppppppp logtype::ABC.123 qqqqqid::IDB-28123.qqqq pppppppp username::qqq
pppppppppppp logtype::ABC.123 rrrrrrid::IDB-28123.rrr pppppppp username::rrTEST`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}