package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)logtype::[^ ]*\s+\w+id::IDB-28123.\w+\s\w+\s+username::\w+TEST`)
var str = ` pppppppppppp logtype::ABC.123 pppppppid::IDB-28123.ppppp pppppppp username::ppppppp
pppppppppppp logtype::ABC.123 qqqqqid::IDB-28123.qqqq pppppppp username::qqq
pppppppppppp logtype::ABC.123 rrrrrrid::IDB-28123.rrr pppppppp username::rrTEST`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}