using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-Z]{1,2}\d{1,2}(?:(?: )?\d[A-Z]{2})?$";
string input = @"AA9
AA99
AA9 9ZZ
AA99 9ZZ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}