$re = '/^[A-Z]{1,2}\d{1,2}(?:(?: )?\d[A-Z]{2})?$/m';
$str = 'AA9
AA99
AA9 9ZZ
AA99 9ZZ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);