package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Z]{1,2}\d{1,2}(?:(?: )?\d[A-Z]{2})?$`)
var str = `AA9
AA99
AA9 9ZZ
AA99 9ZZ`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}