#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?-s)^(?=.*LckEXPR_).*\KX2"
Local $sString = "abLckEXPR_cX2" & @CRLF & _
"cab" & @CRLF & _
"X2c LckEXPR_ cc" & @CRLF & _
"z aX2 cLckEXPR_" & @CRLF & _
"dd ab c" & @CRLF & _
"c abcccc"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")