using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?-s)^(?=.*LckEXPR_).*\KX2";
string input = @"abLckEXPR_cX2
cab
X2c LckEXPR_ cc
z aX2 cLckEXPR_
dd ab c
c abcccc";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}