$re = '/(?-s)^(?=.*LckEXPR_).*\KX2/m';
$str = 'abLckEXPR_cX2
cab
X2c LckEXPR_ cc
z aX2 cLckEXPR_
dd ab c
c abcccc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);