const regex = /(?-s)^(?=.*LckEXPR_).*\KX2/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?-s)^(?=.*LckEXPR_).*\\KX2', 'gm')
const str = `abLckEXPR_cX2
cab
X2c LckEXPR_ cc
z aX2 cLckEXPR_
dd ab c
c abcccc`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}