#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^(?<rank>(?:(?:[ \t]|^)[a-z]+)+?)(?!(?:[ \t][a-z.]+){4,}$)[ \t](?<first>[a-z]+)[ \t](?:(?<middle>[a-z.]+)[ \t])?(?<last>[a-z]+)$"
Local $sString = "High Sheriff John Caldwell. Cook" & @CRLF & _
"Deputy Sheriff John A. Gooch" & @CRLF & _
"Marshall Robert Forsyth" & @CRLF & _
"Constable Darius Quimby" & @CRLF & _
"" & @CRLF & _
"#Exception (when you have First, Last and more than 1 word for the rank):" & @CRLF & _
"Deputy Sheriff John Gooch" & @CRLF & _
"" & @CRLF & _
"#In the last example you have to define a list of rank prefixes which mean that there's another word definitely going after it and capture it greedy or with possessive quantifier. E.g.: Deputy,High."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")