$re = '/^(?<rank>(?:(?:[ \t]|^)[a-z]+)+?)(?!(?:[ \t][a-z.]+){4,}$)[ \t](?<first>[a-z]+)[ \t](?:(?<middle>[a-z.]+)[ \t])?(?<last>[a-z]+)$/im';
$str = 'High Sheriff John Caldwell. Cook
Deputy Sheriff John A. Gooch
Marshall Robert Forsyth
Constable Darius Quimby
#Exception (when you have First, Last and more than 1 word for the rank):
Deputy Sheriff John Gooch
#In the last example you have to define a list of rank prefixes which mean that there\'s another word definitely going after it and capture it greedy or with possessive quantifier. E.g.: Deputy,High.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);