use strict;
my $str = 'High Sheriff John Caldwell. Cook
Deputy Sheriff John A. Gooch
Marshall Robert Forsyth
Constable Darius Quimby
#Exception (when you have First, Last and more than 1 word for the rank):
Deputy Sheriff John Gooch
#In the last example you have to define a list of rank prefixes which mean that there\'s another word definitely going after it and capture it greedy or with possessive quantifier. E.g.: Deputy,High.';
my $regex = qr/^(?<rank>(?:(?:[ \t]|^)[a-z]+)+?)(?!(?:[ \t][a-z.]+){4,}$)[ \t](?<first>[a-z]+)[ \t](?:(?<middle>[a-z.]+)[ \t])?(?<last>[a-z]+)$/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}