import Foundation
let pattern = #"^(?<rank>(?:(?:[ \t]|^)[a-z]+)+?)(?!(?:[ \t][a-z.]+){4,}$)[ \t](?<first>[a-z]+)[ \t](?:(?<middle>[a-z.]+)[ \t])?(?<last>[a-z]+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = ##"""
High Sheriff John Caldwell. Cook
Deputy Sheriff John A. Gooch
Marshall Robert Forsyth
Constable Darius Quimby
#Exception (when you have First, Last and more than 1 word for the rank):
Deputy Sheriff John Gooch
#In the last example you have to define a list of rank prefixes which mean that there's another word definitely going after it and capture it greedy or with possessive quantifier. E.g.: Deputy,High.
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)